Terminally Incoherent

Utterly random, incoherent and disjointed rants and ramblings...

Tuesday, July 19, 2005

Update the Monkey!

Please go and update your Greasemonkey now! Authors warn that there is a very serious security hole in all versions < 0.3.5. Apparently some scripts can expose contents of your hard drive to the viewed site. Some user scripts can be exploited badly.

0.3.5 is a neutered release with the GM* API disabled. It might break some of your scripts, but if you are like me, and use GM sparingly, you should be fine. The little blogger script I use still works!

Please note the newest version didn't go through the automatic update feature yet. I had to go pull up the Extensions dialog and update it manually. The auto update might catch it sometime soon, but I figured I'll patch it as soon as possible.

Fortunately, there are no known exploits yet, but better safe than sorry :)


0 Comments:

Post a Comment

Links to this post:

Create a Link

<< Home